<!DOCTYPE html>
<!--[if lt IE 7]>      <html class="no-js lt-ie9 lt-ie8 lt-ie7"> <![endif]-->
<!--[if IE 7]>         <html class="no-js lt-ie9 lt-ie8"> <![endif]-->
<!--[if IE 8]>         <html class="no-js lt-ie9"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js"> <!--<![endif]-->
    <head>
				<link href='https://fonts.googleapis.com/css?family=Lora:400,400italic,700,700italic|Lato:400,700,900,400italic,700italic,900italic' rel='stylesheet' type='text/css'>
        <meta charset="utf-8">
        <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
				<title>Doug Creamer column: He needs us - Salisbury Post | Salisbury Post</title>

								<script type="text/javascript">
					<!--
					if (screen.availWidth && screen.availWidth < 481) {
							//Conditional script here
              window.location.href = "https://" + "m.salisburypost.com" + window.location.pathname 
					}
					//-->
				</script>

								<link rel="stylesheet" type="text/css" media="screen" href="https://www.salisburypost.com/wp-content/themes/2016-bni/media/js/vendor/jquery.bxslider/jquery.bxslider.css?1592033368" />
				<link rel="stylesheet" href="https://www.salisburypost.com/wp-content/themes/2016-bni/media/css/normalize.css?1592033368" />
				<link rel="stylesheet" href="https://www.salisburypost.com/wp-content/themes/2016-bni/media/css/base.css?1596134105" />
				<link rel="stylesheet" type="text/css" media="screen" href="https://www.salisburypost.com/wp-content/themes/2016-bni/style.css?1597348380" />

        <script src="https://www.salisburypost.com/wp-content/themes/2016-bni/media/js/vendor/modernizr-2.6.2.min.js?1592033368"></script>

				<link rel="Shortcut Icon" type="image/ico" href="https://www.salisburypost.com/wp-content/themes/2016-salisbury-child/media/img/brand/favicon-salisburypost.png">

				
																
<!-- This site is optimized with the Yoast SEO plugin v12.1 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://www.salisburypost.com/2020/08/16/doug-creamer-column-he-needs-us/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Doug Creamer column: He needs us - Salisbury Post" />
<meta property="og:description" content="By Doug Creamer I was talking with a friend the other day and was reminded of the first couple of years of our married lives. When we got married, we moved to the quiet town of Kenansville, in rural Duplin County. We loved our first years in Kenansville. Being young, we often wondered why we &hellip;" />
<meta property="og:url" content="https://www.salisburypost.com/2020/08/16/doug-creamer-column-he-needs-us/" />
<meta property="og:site_name" content="Salisbury Post" />
<meta property="article:author" content="https://www.facebook.com/SalPostLifestyle/" />
<meta property="article:section" content="Lifestyle" />
<meta property="article:published_time" content="2020-08-16T04:00:04-04:00" />
<meta property="article:modified_time" content="2020-08-13T04:37:13-04:00" />
<meta property="og:updated_time" content="2020-08-13T04:37:13-04:00" />
<meta property="og:image" content="https://www.salisburypost.com/wp-content/uploads/sites/9/2020/01/facebook-salisburypost.png" />
<meta property="og:image:secure_url" content="https://www.salisburypost.com/wp-content/uploads/sites/9/2020/01/facebook-salisburypost.png" />
<meta property="og:image:width" content="398" />
<meta property="og:image:height" content="208" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="By Doug Creamer I was talking with a friend the other day and was reminded of the first couple of years of our married lives. When we got married, we moved to the quiet town of Kenansville, in rural Duplin County. We loved our first years in Kenansville. Being young, we often wondered why we [&hellip;]" />
<meta name="twitter:title" content="Doug Creamer column: He needs us - Salisbury Post" />
<meta name="twitter:image" content="https://www.salisburypost.com/wp-content/uploads/sites/9/2020/01/facebook-salisburypost.png" />
<meta name="twitter:creator" content="@postlifestyles" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.salisburypost.com/#website","url":"https://www.salisburypost.com/","name":"Salisbury Post","potentialAction":{"@type":"SearchAction","target":"https://www.salisburypost.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"https://www.salisburypost.com/2020/08/16/doug-creamer-column-he-needs-us/#webpage","url":"https://www.salisburypost.com/2020/08/16/doug-creamer-column-he-needs-us/","inLanguage":"en-US","name":"Doug Creamer column: He needs us - Salisbury Post","isPartOf":{"@id":"https://www.salisburypost.com/#website"},"datePublished":"2020-08-16T04:00:04-04:00","dateModified":"2020-08-13T04:37:13-04:00","author":{"@id":"https://www.salisburypost.com/#/schema/person/52545c729bdf50d1bffc30a1dec741f8"}},{"@type":["Person"],"@id":"https://www.salisburypost.com/#/schema/person/52545c729bdf50d1bffc30a1dec741f8","name":"Post Lifestyles","image":{"@type":"ImageObject","@id":"https://www.salisburypost.com/#authorlogo","url":"https://www.salisburypost.com/wp-content/uploads/sites/9/2020/01/Clock-Tower-logo-copy.jpg?w=54","caption":"Post Lifestyles"},"description":"Visit us on Facebook: https://www.facebook.com/SalPostLifestyle/ and Twitter @postlifestlyes for more content","sameAs":["https://www.facebook.com/SalPostLifestyle/","https://twitter.com/postlifestyles"]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Salisbury Post &raquo; Doug Creamer column: He needs us Comments Feed" href="https://www.salisburypost.com/2020/08/16/doug-creamer-column-he-needs-us/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.salisburypost.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0' href='https://www.salisburypost.com/_static/??-eJx9UNtuwyAM/aEBSbtL9zD1W4CQxQ03YaMufz8nbadOUfKCLJ/DuVhds4Bofe0cKouoOo0D2BRRBoiSNy/qmXJBRYyPJv38DWvWIgRIyvhkR+HBFF0mhTR590+XjchFUtnXb4iogqOSoiORS+rBO5HBUi3uSQ3lTcZU8N22UMs2cHWaBleEiSBkIw/SLNEe652eM013DAmjy25kXuXkParlFUzbpCKEzJ2QdN/zUbhRrsaDXdxWoLiBKzWOHjjhoWnf52L3q+6xULOeqWUSduCjbfwIVTyCXhxlbccl132e6efw1b59fhxfT8dT8wsdS9LJ' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<style id='admin-bar-inline-css'>
#wp-admin-bar-my-sites-search.hide-if-no-js {
	display: none;
}
#wp-admin-bar-my-sites-search label[for="my-sites-search-text"] {
	clip: rect(1px, 1px, 1px, 1px);
	position: absolute !important;
	height: 1px;
	width: 1px;
	overflow: hidden;
}
#wp-admin-bar-my-sites-search {
	height: 38px;
}
#wp-admin-bar-my-sites-search .ab-item {
	height: 34px;
}
#wp-admin-bar-my-sites-search input {
	padding: 0 2px;
	width: 95%;
	width: calc( 100% - 4px );
}
	
</style>
<style id='wp-polls-inline-css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://www.salisburypost.com/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<script src='https://www.salisburypost.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script>
jQuery(document).ready( function($) {
	$('#wp-admin-bar-my-sites-search.hide-if-no-js').show();
	$('#wp-admin-bar-my-sites-search input').keyup( function( ) {

		var searchValRegex = new RegExp( $(this).val(), 'i');

		$('#wp-admin-bar-my-sites-list > li.menupop').hide().filter(function() {

			return searchValRegex.test( $(this).find('> a').text() );

		}).show();

	});
});
	
</script>
<script type='text/javascript' src='https://www.salisburypost.com/wp-includes/js/jquery/jquery-migrate.min.js?m=1591831629g'></script>
<link rel='https://api.w.org/' href='https://www.salisburypost.com/wp-json/' />
<link rel='shortlink' href='https://www.salisburypost.com/?p=472330' />
<link rel="alternate" type="application/json+oembed" href="https://www.salisburypost.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.salisburypost.com%2F2020%2F08%2F16%2Fdoug-creamer-column-he-needs-us%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.salisburypost.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.salisburypost.com%2F2020%2F08%2F16%2Fdoug-creamer-column-he-needs-us%2F&#038;format=xml" />
<link href="https://trinitymedia.ai" rel="preconnect" crossorigin="anonymous" />
<link href="https://vd.trinitymedia.ai" rel="preconnect" crossorigin="anonymous" />
<style type='text/css'>img#wpstats{display:none}</style><!-- Global site tag (gtag.js) - Google Analytics -->
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-34177675-1', 'auto');
  ga('send', 'pageview');
</script>
											<script type="text/javascript">
					document.write(unescape("%3Cscript src='https://subscriptions.salisburypost.com/bwtw/scripts/tw.js' type='text/javascript'%3E%3C/script%3E"));
				</script>
				<script type="text/javascript">

					
					_bwtp = new TheWall('https://subscriptions.salisburypost.com/bwtw/', 'SP', 'SP', null, 'DEFAULT');

          var pw_total_val = '0';
          var pw_read_val = '0';

					_bwtp.init();
          loggedin = _bwtp.userStatus();
          _bwtp.status(function(f) { 
            pw_total_val = f.viewRate.AllowedViews;
            pw_read_val = f.viewRate.NumViews;
          });

					jQuery(window).load(function() { // These functions get called when everything has loaded
						if (!loggedin) {
							jQuery("#supNav").append('<li><a href="#" onclick="_bwtp.Auth(true);">Log In</a></li>');
              if (( pw_total_val > 0 ) && ( pw_read_val <= pw_total_val ) && ( jQuery('body').attr("id") != "homePage")) {
                var paywall_info_content = '<div id="paywall_info_box" style="padding: 1em 0; margin: 1em 0; font-weight: bold; border-top: 1px solid #aaa; border-bottom: 1px solid #aaa; text-align: center; color: #222;">' +
                  '<p style="font-weight: bold;">You have read ' + pw_read_val + ' of ' + pw_total_val + ' articles.</p>' +
                  '<p style="margin-bottom: 0; font-weight: bold;"><a href="#" onclick="_bwtp.Auth(true);" style="color: #92191f;">Log In or Subscribe</a></p>' + 
                  '</div>';
                jQuery(paywall_info_content).appendTo('div#article div.byline').fadeIn();
              }

						} else {
							jQuery("#supNav").append('<li><a href="#" onclick="_bwtp.clearID();">Log Out</a></li>');
						}
					});
				</script>


				<script type="text/javascript" src="https://www.salisburypost.com/wp-content/themes/2016-bni/media/js/colorbox/jquery.colorbox-min.js"></script>
				<link rel="stylesheet" type="text/css" media="screen" href="https://www.salisburypost.com/wp-content/themes/2016-bni/media/js/colorbox/colorbox.css" />

        <script type="text/javascript">!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://gondolagnome.com/v2/0/qgm--t1cSnkJXHwvoo7JKXT4-fniaL7GoKdYaAHjVpaT3LGQD-2yOxsw17xqTxCsa1eU6UZ1N43JR0",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){o[n]=o[n]||function(){(o[n].q=o[n].q||[]).push(arguments)}})(window,"admiral");!(function(n,e,r,t){function o(){if((function o(t){try{return(t=localStorage.getItem("v4ac1eiZr0"))&&0<t.split(",")[4]}catch(n){}return!1})()){var t=n[e].pubads();typeof t.setTargeting===r&&t.setTargeting("admiral-engaged","true")}}(t=n[e]=n[e]||{}).cmd=t.cmd||[],typeof t.pubads===r?o():typeof t.cmd.unshift===r?t.cmd.unshift(o):t.cmd.push(o)})(window,"googletag","function");;;;;</script>

<script async src="https://sync.serverbid.com/ss/2000707.js"></script>


<meta property="fb:app_id" content="168913723140235" />
				<script async src="//js-sec.indexww.com/ht/p/188239-192868292012837.js"></script>
<script src="https://storage.googleapis.com/didna-files/utility/didna_logging_util.min.js"></script>
<script id="optimera-ops" src="https://d15kdpgjg3unno.cloudfront.net/oPS.js?cid=57" data-cid="57"></script>

<!-- Invisibly Pixel Code -->
<script>
 window.ia = window.ia || function (){
 (window.ia.q = window.ia.q || []).push(arguments); };
 ia('track', 'PAGE_VIEW');
</script>
<script src="https://pymx5.com/scripts/ready.js"></script>
<script src='https://pymx5.com/scripts/ims.js'></script>
<script async src='https://pymx5.com/scripts/load_tags.js'></script>
<noscript><img height="1" width="1" style="display:none" src="https://api.pymx5.com/v1/sites/track?event_type=PAGE_VIEW&noscript=1"/></noscript>
<script >docReady(function(){ ims.startServices(); });</script>



    <script src='https://www.googletagservices.com/tag/js/gpt.js'></script>


<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>


<script>
googletag.cmd.push(function() {

    			googletag.defineSlot('/1613683/SNL-160x600-1', [160, 600], 'div-gpt-ad-skyscraper').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-300x250-16', [300, 250], 'div-gpt-ad-instory-top').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-300x250-17', [300, 250], 'div-gpt-ad-instory-bottom').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-300x250-instory-third', [300, 250], 'div-gpt-ad-instory-third').addService(googletag.pubads());
			FEATUREDGALLERY_AD = googletag.defineSlot('/1613683/SNL-300x250-featured_gallery', [300, 250], 'div-gpt-ad-bigblock-featured_gallery').addService(googletag.pubads());

  if (!loggedin) {
			googletag.defineSlot('/1613683/SNL-1x1-2', [1,1], 'div-gpt-ad-extra_one_by_one').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-1x1-3', [1,1], 'div-gpt-ad-extra_oop').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-1x1-4', [1,1], 'div-gpt-ad-extra_one_by_one_two').addService(googletag.pubads());
  }

    			googletag.defineSlot('/1613683/SNL-300x100-1', [300, 100], 'div-gpt-ad-skybox').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-300x250-1', [[300, 600], [300, 250]], 'div-gpt-ad-bigblock-1').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-300x250-2', [[300, 600], [300, 250]], 'div-gpt-ad-bigblock-2').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-300x250-3', [[300, 600], [300, 250]], 'div-gpt-ad-bigblock-3').addService(googletag.pubads());

			googletag.defineSlot('/1613683/SNL-300x600-1', [[300, 600], [160, 600]], 'div-gpt-ad-halfpage-1').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-970x90-1', [[970, 90], [970, 250], [728, 90]], 'div-gpt-ad-largeleaderboard').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-1x1-duration', [1,1], 'div-gpt-ad-one_by_one_duration').addService(googletag.pubads());

  if (!loggedin) {
			googletag.defineSlot('/1613683/SNL-300x250-18', [300, 250], 'div-gpt-ad-bigblock-18').addService(googletag.pubads());
			googletag.defineSlot('/1613683/SNL-1x1-wall', [1,1], 'div-gpt-ad-one_by_one_wall').addService(googletag.pubads());
			googletag.defineOutOfPageSlot('/1613683/SNL-1x1-1', 'div-gpt-ad-screenshift').addService(googletag.pubads());
  }

          googletag.pubads().setTargeting("catname", "faith");
    
          googletag.pubads().setTargeting("pageurl", "/2020/08/16/doug-creamer-column-he-needs");
    
      // TESTING 1.1
    // Lazy Load settings
    googletag.pubads().enableLazyLoad({
      fetchMarginPercent: 2,  // Fetch slots within .02 viewports.
      renderMarginPercent: 1,  // Render slots within .01 viewports.
      mobileScaling: 0  // same value on mobile.
    });
    
		googletag.pubads().enableSingleRequest();
		//googletag.pubads().collapseEmptyDivs()
    googletag.pubads().disableInitialLoad();
    googletag.enableServices();

});
</script>




<script>
//load the apstag.js library
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");

//initialize the apstag.js library on the page to allow bidding
apstag.init({
     pubID:  '26673ab7-6c90-4748-8b4c-71512dcf8ef3', //enter your pub ID here as shown above, it must within quotes
     adServer: 'googletag'
});
apstag.fetchBids({
     slots: [{
          slotID: 'div-gpt-ad-skyscraper',
          slotName: '1613683/SNL-160x600-1',
          sizes: [[160, 600]]
      },
      //{
          //slotID: 'div-gpt-ad-skybox',
          //slotName: '1613683/SNL-300x100-1',
          //sizes: [[300, 100]]
      //},
      //{
          //slotID: 'div-gpt-ad-threesix-1',
          //slotName: '1613683/SNL-300x600-1',
          //sizes: [[300, 600]]
      //},
      {
          slotID: 'div-gpt-ad-bigblock-1',
          slotName: '1613683/SNL-300x250-1',
          sizes: [[300, 600], [300, 250]]
      },
      {
          slotID: 'div-gpt-ad-bigblock-2',
          slotName: '1613683/SNL-300x250-2',
          sizes: [[300, 600], [300, 250]]
      },
			{
					slotID: 'div-gpt-ad-bigblock-3',
					slotName: '1613683/SNL-300x250-3',
					sizes: [[300, 600], [300, 250]]
			},
      {
          slotID: 'div-gpt-ad-bigblock-4',
          slotName: '1613683/SNL-300x250-4',
          sizes: [[300, 250]]
      },
      {
          slotID: 'div-gpt-ad-bigblock-5',
          slotName: '1613683/SNL-300x250-5',
          sizes: [[300, 250]]
      },
			{
					slotID: 'div-gpt-ad-bigblock-6',
					slotName: '1613683/SNL-300x250-6',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-7',
					slotName: '1613683/SNL-300x250-7',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-8',
					slotName: '1613683/SNL-300x250-8',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-9',
					slotName: '1613683/SNL-300x250-9',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-10',
					slotName: '1613683/SNL-300x250-10',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-11',
					slotName: '1613683/SNL-300x250-11',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-12',
					slotName: '1613683/SNL-300x250-12',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-13',
					slotName: '1613683/SNL-300x250-13',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-14',
					slotName: '1613683/SNL-300x250-14',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-15',
					slotName: '1613683/SNL-300x250-15',
					sizes: [[300, 250]]
			},
      {
          slotID: 'div-gpt-ad-instory-top',
          slotName: '1613683/SNL-300x250-16',
          sizes: [[300, 250]]
      },
      {
          slotID: 'div-gpt-ad-instory-bottom',
          slotName: '1613683/SNL-300x250-17',
          sizes: [[300, 250]]
      },
      //{
          //slotID: 'div-gpt-ad-bigblock-18',
          //slotName: '1613683/SNL-300x250-18',
          //sizes: [[300, 250]]
      //},
      //{
          //slotID: 'div-gpt-ad-instory-third',
          //slotName: '1613683/SNL-300x250-instory-third',
          //sizes: [[300, 250]]
      //},
      {
          slotID: 'div-gpt-ad-mobile-sticky',
          slotName: '1613683/SNL-320x50-1',
          sizes: [[320, 50], [1, 1]]
      },
      {
          slotID: 'div-gpt-ad-largeleaderboard',
          slotName: '1613683/SNL-970x90-1',
          sizes: [[970, 90], [728, 90], [970, 250]]
     }],
     timeout: 2e3
}, function(bids) {
     // set apstag targeting on googletag, then trigger the first DFP request in googletag's disableInitialLoad integration
     googletag.cmd.push(function(){
         apstag.setDisplayBids();
				 googletag.pubads().refresh();
     });
}); 
</script>


        <script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>


    </head>
		<body id="articlePage">
        <!--[if lt IE 7]>
            <p class="chromeframe">You are using an <strong>outdated</strong> browser. Please <a href="http://browsehappy.com/">upgrade your browser</a> or <a href="http://www.google.com/chromeframe/?redirect=true">activate Google Chrome Frame</a> to improve your experience.</p>
        <![endif]-->
																<!-- Paste this after your <body> tag. Fill in "ARTICLE_URL" and "CONTENT_ID" --> 
				<script type="text/javascript"> 
				(function() { 
					var ARTICLE_URL = 'https://www.salisburypost.com/2020/08/16/doug-creamer-column-he-needs-us/'; 
					var CONTENT_ID = ''; // Optional or leave empty 
					document.write( 
						'<scr'+'ipt '+ 
						'src="//survey.g.doubleclick.net/survey?site=_acby66y5aly33aqou3rkicnpnu'+ 
						'&amp;url='+encodeURIComponent(ARTICLE_URL)+ 
						(CONTENT_ID ? '&amp;cid='+encodeURIComponent(CONTENT_ID) : '')+ 
						'&amp;random='+(new Date).getTime()+ 
						'" type="text/javascript">'+'\x3C/scr'+'ipt>'); 
          })(); 

          jQuery(document).ready(function() { // These functions get called on DOM ready
						if (!loggedin) {
							load_402_show_function();
						}
          });
				</script> 
				

				<div id="" class="undertone">


					<!-- Add your site or application content here -->

          <div id="sup_nav" class="sup_nav">

						<div class="ad large_leaderboard">
							<div class="ad970x90 large_leaderboard"><!-- ROS_970x90 -->
<div id='div-gpt-ad-largeleaderboard'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-largeleaderboard'); });
  </script>
</div></div>
						</div>

						<div class="wrapper">
							<ul id="supNav">
	<li class="">
		<a href="https://www.salisburypost.com/customer-service/">Submit</a>
		<ul class="sub-nav">
			<li><a href="https://www.salisburypost.com/customer-service/">Contact Us</a></li>
			<li><a href="https://docs.google.com/forms/d/e/1FAIpQLSfYRDDgs1wEHwOar6avWhnT-NBuQmtB12wRBJNEekuTbtM7-g/viewform">Submit Obituary</a></li>
			<li><a href="https://www.salisburypost.com/services/submit-a-news-tip/">Submit a News Tip</a></li>
			<li><a href="https://www.salisburypost.com/services/submit-letter/">Letter to the Editor</a></li>
			<li><a href="http://marketplace.salisburypost.com/Salisbury/">Place a Classified Ad</a></li>
			<li><a href="mailto:sales@salisburypost.com">Place a Retail Ad</a></li>
			<li><a href="https://portal.cityspark.com/EventEntry/EventEntry/SalisburyPost">Submit Community Calendar Event</a></li>
			<li><a href="https://www.salisburypost.com/celebrations-forms-and-info/">Celebrations Forms</a></li>
			<li><a href="https://www.salisburypost.com/submit-a-birthday/">Birthday Form</a></li>
			<li><a href="https://www.salisburypost.com/services/submit-a-birth-announcement/">Birth Announcement</a></li>
			<li><a href="https://www.salisburypost.com/services/submit-delays-or-closings/">Submit Delays or Closing</a></li>
			<li><a href="mailto:news@salisburypost.com">Submit a Correction</a></li>
		</ul>
	</li>
	<li class=""><a href="https://subscriptions.salisburypost.com/CircStore/Account/Login?vendor=DirXion&prodId=SP">E-edition</a></li>
	<li class=""><a href="https://www.salisburypost.com/insider">Email Sign-Up</a></li>
	<li class=""><a href="https://marketplace.salisburypost.com/Salisbury/">Place an Ad</a></li>
	<li class="subscribe"><a href="http://www.salisburypost.com/subscriptions/">Subscriptions</a></li>
	<li class=""><a href="http://www.salisburythemagazine.com/">SALISBURY the magazine</a></li>
	<li class=""><a href="http://marketplace.salisburypost.com/AdHunter/SalisburyPost/Home/Search?majorClass=1000">Jobs</a></li>
  <li class="RoCo Gold"><a href="http://www.rocogold.com">RoCo Gold Awards</a></li>    
	<li class=""><a href="https://www.salisburypost.com/special-sections/">Special Sections</a></li>
</ul>							<p class="date">
								August 16, 2020							</p>
							<div class="clearfix"></div>
						</div>
					</div>
					<div id="main_body" class="wrapper">

							
            						<header id="main_header">
							<div id="search_weather">
								<div id="weather">
									<div class="details">
										<ul>
											<li id="m1_miniweather_widget-3" class="widget widget_m1_miniweather_widget"><h2 class="widgettitle"></h2>
<div class="wi wi-owm-804" title="overcast clouds" style="font-size: 2em;">
			       <span class="m1mw_temp">66&deg;</span>
			     </div></li>
										</ul>
																				</div>
									<div class="clearfix"></div>
								</div>
								<div class="ad sponsorship">
										<!-- ROS_300x100_Skybox_Teaser -->
<div id='div-gpt-ad-skybox' style='height:100px; width:300px;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-skybox'); });
  </script>
</div>								</div>
							</div>
            							<div id="logo">
								<a href="https://www.salisburypost.com">
									<img src="https://www.salisburypost.com/wp-content/themes/2016-salisbury-child/media/img/brand/logo-salisburypost.png" alt="Salisbury Post" />
								</a>
							</div>
							<div class="clearfix"></div>
							<nav id="navbar">
								<a href="https://www.salisburypost.com">
									<img class="logo" class="logo" src="https://www.salisburypost.com/wp-content/themes/2016-salisbury-child/media/img/brand/logo-salisburypost.png" alt="Salisbury Post" />
								</a>
								<ul id="mainNav">
	<li class="home "><a href="https://www.salisburypost.com">Home</a></li>
	<li class="news "><a href="https://www.salisburypost.com/category/news/">News</a>
		<!-- NEWS DROP -->
		<ul class="sub-nav">
			<li>
				<div class="contents">
					<div class="col first">
						<h3 class="section">In News</h3>
            <ul class="left">
                <li><a href="https://www.salisburypost.com/category/news/local/" title="Local News | Salisbury, North Carolina - The Salisbury Post">Local</a></li>
                <li><a href="https://www.salisburypost.com/category/business/" title="Business News | Salisbury, North Carolina - The Salisbury Post">Business</a></li>
                <li><a href="https://www.salisburypost.com/category/education/" title="Education News | Salisbury, North Carolina - The Salisbury Post">Education</a></li>
		<li><a href="https://www.salisburypost.com/category/grad/" title="Graduation | Rowan County, NC - The Salisbury Post">Graduation</a></li>
                <li><a href="https://www.salisburypost.com/category/trial/" title="Local Trial Coverage - The Salisbury Post">Trials</a></li>
                <li><a href="https://www.salisburypost.com/category/crime/" title="Crime | Salisbury, North Carolina - The Salisbury Post">Crime</a></li>
                <li><a href="https://www.salisburypost.com/category/lifestyle/" title="Lifestyle | Salisbury, North Carolina - The Salisbury Post">Lifestyle</a></li>
            </ul>
            <ul class="right">
		<li><a href="https://www.salisburypost.com/category/news/politics/" title="Politics | Salisbury, North Carolina - The Salisbury Post">Politics</a></li>
		<li><a href="http://www.salisburypost.com/2016candidatedirectory/" title="Candidate Directory | Salisbury, North Carolina - The Salisbury Post">Candidate Directory</a></li>
                <li><a href="https://www.salisburypost.com/category/news/kannapolis/" title="Kannapolis News | Salisbury, North Carolina - The Salisbury Post">Kannapolis</a></li>
                <li><a href="https://www.salisburypost.com/category/news/wineka/" title="Wineka | Salisbury, North Carolina - The Salisbury Post">Wineka</a></li>
                <li><a href="https://www.salisburypost.com/category/opinion/columns-opinion/" title="Columns | Salisbury, North Carolina - The Salisbury Post">Columns</a></li>
                <li><a href="https://www.salisburypost.com/category/usworld/" title="Nation/World | Salisbury, North Carolina - The Salisbury Post">Nation/World</a></li>
                <li class="Marketplace"><a href="https://www.youtube.com/user/salisburypostnc">Video</a></li>
            </ul>

					</div>
					<div class="col">
						<h3 class="section">Top News</h3>
												<div class="story">
														<a href="https://www.salisburypost.com/2020/08/16/taken-too-soon-retired-soldier-remembered-as-good-teammate-in-life-battle/" rel="bookmark">
								<img width="300" height="225" src="https://www.salisburypost.com/wp-content/uploads/sites/9/2020/08/0816-Wendell-Rhodes-3.jpg?w=300" class="attachment-medium size-medium wp-post-image" alt="" srcset="https://www.salisburypost.com/wp-content/uploads/sites/9/2020/08/0816-Wendell-Rhodes-3.jpg 700w, https://www.salisburypost.com/wp-content/uploads/sites/9/2020/08/0816-Wendell-Rhodes-3.jpg?resize=300,225 300w, https://www.salisburypost.com/wp-content/uploads/sites/9/2020/08/0816-Wendell-Rhodes-3.jpg?resize=622,467 622w, https://www.salisburypost.com/wp-content/uploads/sites/9/2020/08/0816-Wendell-Rhodes-3.jpg?resize=467,350 467w" sizes="(max-width: 300px) 100vw, 300px" />							</a>
														<h3><a href="https://www.salisburypost.com/2020/08/16/taken-too-soon-retired-soldier-remembered-as-good-teammate-in-life-battle/" rel="bookmark" title="Taken too soon: Retired soldier remembered as good teammate in life, battle">Taken too soon: Retired soldier remembered as good teammate in life, battle</a></h3>										
							<h4 class="date">Sunday, August 16, 2020 12:10 am</h4>
							<p>SALISBURY — Janiah Hall was struggling. She was working to return to her usual form after suffering an injury earlier in the 2017 track and&nbsp;... 
								<span class="meta">
									<a href="https://www.salisburypost.com/2020/08/16/taken-too-soon-retired-soldier-remembered-as-good-teammate-in-life-battle/" class="noVisit readmore" rel="bookmark">Read&nbsp;more</a>
									| <a href="https://www.salisburypost.com/2020/08/16/taken-too-soon-retired-soldier-remembered-as-good-teammate-in-life-battle/#disqus_thread" class="noVisit comments" rel="bookmark">Add your comment</a>
								</span>
							</p>

						</div><!-- END STORY -->
											</div>
					<div class="col last">
						<h3 class="section">Latest News</h3>
												<div class="story">
							<h3><a href="https://www.salisburypost.com/2020/08/16/local-students-will-have-two-historic-first-days-of-school-next-week/" rel="bookmark" title="Local students will have two historic first days of school next week">Local students will have two historic first days of school next week</a></h3>										

						</div><!-- END STORY -->
												<div class="story">
							<h3><a href="https://www.salisburypost.com/2020/08/16/interpretive-walk-construction-begins-for-dixonville-lincoln-memorial-project-set-to-be-completed-in-december/" rel="bookmark" title="Interpretive walk construction begins for Dixonville-Lincoln Memorial project; set to be completed in December">Interpretive walk construction begins for Dixonville-Lincoln Memorial project; set to be completed in December</a></h3>										

						</div><!-- END STORY -->
												<div class="story">
							<h3><a href="https://www.salisburypost.com/2020/08/16/robert-trump-the-presidents-younger-brother-dead-at-71/" rel="bookmark" title="Robert Trump, the president&#8217;s younger brother, dead at 71">Robert Trump, the president&#8217;s younger brother, dead at 71</a></h3>										

						</div><!-- END STORY -->
												<div class="more_stories">
							<h4><a href="/category/news/">More News</a></h4>
						</div>
					</div>
				</div>
			</li>
		</ul>
		<!-- NEWS DROP END -->
	</li>
	<li class="coronavirus "><a href="https://www.salisburypost.com/category/news/coronavirus/">COVID19</a></li>
	<li class="sports"><a href="https://www.salisburypost.com/category/sports/">Sports</a>
		<!-- SPORTS DROP -->
		<ul class="sub-nav">
			<li>
				<div class="contents">
					<div class="col first">
						<h3 class="section">In Sports</h3>

            <ul class="left">
                <li><a href="https://www.salisburypost.com/category/sports/high-school/" title="High School Sports | Salisbury, North Carolina - The Salisbury Post">High School Sports</a></li>
                <li><a href="https://www.salisburypost.com/category/sports/college/" title="College Sports | Salisbury, North Carolina - The Salisbury Post">College Sports</a></li>
		<li><a href="http://collegebasketball.ap.org/salisburypost/" title="AP College Basketball News and Poll | Salisbury, North Carolina - The Salisbury Post">AP College BB News</a></li>    
		<li><a href="http://collegefootball.ap.org/salisburypost/" title="AP College Football News and Poll | Salisbury, North Carolina - The Salisbury Post">AP College FB News</a></li>
		<li><a href="http://pro32.ap.org/salisburypost/" title="AP Pro Football News and Poll | Salisbury, North Carolina - The Salisbury Post">AP Pro Football News</a></li>
		<li><a href="http://racing.ap.org/salisburypost/" title="AP NASCAR Home | Salisbury, North Carolina - The Salisbury Post">AP NASCAR Home</a></li>
             </ul>

					</div>
					<div class="col">
						<h3 class="section">Top Sports</h3>
												<div class="story">
														<a href="https://www.salisburypost.com/2020/08/09/legends-hairston-made-d-i-impact-with-rebounds-defense/" rel="bookmark">
								<img width="300" height="207" src="https://www.salisburypost.com/wp-content/uploads/sites/9/2020/08/0809sp-Hairston.Junior-closeup.jpg?w=300" class="attachment-medium size-medium wp-post-image" alt="" srcset="https://www.salisburypost.com/wp-content/uploads/sites/9/2020/08/0809sp-Hairston.Junior-closeup.jpg 700w, https://www.salisburypost.com/wp-content/uploads/sites/9/2020/08/0809sp-Hairston.Junior-closeup.jpg?resize=300,207 300w, https://www.salisburypost.com/wp-content/uploads/sites/9/2020/08/0809sp-Hairston.Junior-closeup.jpg?resize=622,430 622w, https://www.salisburypost.com/wp-content/uploads/sites/9/2020/08/0809sp-Hairston.Junior-closeup.jpg?resize=506,350 506w" sizes="(max-width: 300px) 100vw, 300px" />							</a>
														<h3><a href="https://www.salisburypost.com/2020/08/09/legends-hairston-made-d-i-impact-with-rebounds-defense/" rel="bookmark" title="Legends: Hairston made D-I impact with rebounds, defense">Legends: Hairston made D-I impact with rebounds, defense</a></h3>										
							<h4 class="date">Sunday, August 9, 2020 12:00 am</h4>
							<p>By Mike London mike.london@salisburypost.com SALISBURY— When they hang out in dorms and apartments, college basketball players tend to start bragging about high school careers. In&nbsp;... 
								<span class="meta">
									<a href="https://www.salisburypost.com/2020/08/09/legends-hairston-made-d-i-impact-with-rebounds-defense/" class="noVisit readmore" rel="bookmark">Read&nbsp;more</a>
									| <a href="https://www.salisburypost.com/2020/08/09/legends-hairston-made-d-i-impact-with-rebounds-defense/#disqus_thread" class="noVisit comments" rel="bookmark">Add your comment</a>
								</span>
							</p>

						</div><!-- END STORY -->
											</div>
					<div class="col last">
						<h3 class="section">Latest Sports</h3>
												<div class="story">
							<h3><a href="https://www.salisburypost.com/2020/08/16/track-brothers-battled-for-a-championship-in-1966/" rel="bookmark" title="Track: Barger brothers battled for a championship in 1966">Track: Barger brothers battled for a championship in 1966</a></h3>										

						</div><!-- END STORY -->
												<div class="story">
							<h3><a href="https://www.salisburypost.com/2020/08/16/baseball-easts-mako-commits-to-wolfpack/" rel="bookmark" title="Baseball: East&#8217;s Mako commits to Wolfpack">Baseball: East&#8217;s Mako commits to Wolfpack</a></h3>										

						</div><!-- END STORY -->
												<div class="story">
							<h3><a href="https://www.salisburypost.com/2020/08/15/cole-posts-20th-straight-regular-season-win-yanks-top-bosox/" rel="bookmark" title="Cole posts 20th straight regular-season win as Yanks top Bosox">Cole posts 20th straight regular-season win as Yanks top Bosox</a></h3>										

						</div><!-- END STORY -->
												<div class="more_stories">
							<h4><a href="/category/sports/">More Sports</a></h4>
						</div>
					</div>
				</div>
			</li>
		</ul>
		<!-- SPORTS DROP END -->
	</li>
	<li class="opinion"><a href="https://www.salisburypost.com/category/opinion/">Opinion</a>
		<!-- OPINION DROP -->
		<ul class="sub-nav">
			<li>
				<div class="contents">
					<div class="col first">
						<h3 class="section">In Opinion</h3>
            <ul class="left">
                <li><a href="https://www.salisburypost.com/category/opinion/columns-opinion/" title="Opinion - Columns | Salisbury, North Carolina - The Salisbury Post">Columns</a></li>
                <li><a href="https://www.salisburypost.com/category/opinion/common-sense/" title="Opinion - Common Sense | Salisbury, North Carolina - The Salisbury Post">Common Sense</a></li>
                <li><a href="https://www.salisburypost.com/category/opinion/letters/" title="Opinion - Letters | Salisbury, North Carolina - The Salisbury Post">Letters</a></li>
            </ul>
            <ul class="right">
                <li><a href="https://www.salisburypost.com/services/submit-letter/" target="_blank" title="Opinion - Submit a Letter | Salisbury, North Carolina - The Salisbury Post">Submit a Letter</a></li>
                <li><a href="https://www.salisburypost.com/category/opinion/editorials/" title="Opinion - Editorials | Salisbury, North Carolina - The Salisbury Post">Editorials</a></li>
                <li><a href="https://www.salisburypost.com/category/opinion/brincefield-cartoons/" title="Opinion - Brincefield Cartoons | Salisbury, North Carolina - The Salisbury Post">Brincefield Cartoons</a></li>
            </ul>

					</div>
					<div class="col">
						<h3 class="section">Top Opinion</h3>
												<div class="story">
														<a href="https://www.salisburypost.com/2020/08/16/josh-bergeron-decades-ago-and-eras-apart-viewer-experience-was-different/" rel="bookmark">
								<img width="300" height="171" src="https://www.salisburypost.com/wp-content/uploads/sites/9/2020/08/TERRACE-THEATRE1.jpg?w=300" class="attachment-medium size-medium wp-post-image" alt="" srcset="https://www.salisburypost.com/wp-content/uploads/sites/9/2020/08/TERRACE-THEATRE1.jpg 622w, https://www.salisburypost.com/wp-content/uploads/sites/9/2020/08/TERRACE-THEATRE1.jpg?resize=300,171 300w, https://www.salisburypost.com/wp-content/uploads/sites/9/2020/08/TERRACE-THEATRE1.jpg?resize=613,350 613w" sizes="(max-width: 300px) 100vw, 300px" />							</a>
														<h3><a href="https://www.salisburypost.com/2020/08/16/josh-bergeron-decades-ago-and-eras-apart-viewer-experience-was-different/" rel="bookmark" title="Josh Bergeron: Decades ago and eras apart, viewer experience was different">Josh Bergeron: Decades ago and eras apart, viewer experience was different</a></h3>										
							<h4 class="date">Sunday, August 16, 2020 12:00 am</h4>
							<p>It was probably a mid-1990s movie. Maybe “Hercules.” It could have been “Batman &amp; Robin,” “Space Jam” or “The Lost World: Jurassic Park.” Particularly when&nbsp;... 
								<span class="meta">
									<a href="https://www.salisburypost.com/2020/08/16/josh-bergeron-decades-ago-and-eras-apart-viewer-experience-was-different/" class="noVisit readmore" rel="bookmark">Read&nbsp;more</a>
									| <a href="https://www.salisburypost.com/2020/08/16/josh-bergeron-decades-ago-and-eras-apart-viewer-experience-was-different/#disqus_thread" class="noVisit comments" rel="bookmark">Add your comment</a>
								</span>
							</p>

						</div><!-- END STORY -->
											</div>
					<div class="col last">
						<h3 class="section">Latest Opinion</h3>
												<div class="story">
							<h3><a href="https://www.salisburypost.com/2020/08/16/letter-read-letter-work-to-improve-theater-scene/" rel="bookmark" title="Letter: Read letter, work to improve theater scene">Letter: Read letter, work to improve theater scene</a></h3>										

						</div><!-- END STORY -->
												<div class="story">
							<h3><a href="https://www.salisburypost.com/2020/08/16/letter-ppt-board-members-should-be-ashamed/" rel="bookmark" title="Letter: PPT board members should be ashamed">Letter: PPT board members should be ashamed</a></h3>										

						</div><!-- END STORY -->
												<div class="story">
							<h3><a href="https://www.salisburypost.com/2020/08/16/letter-in-time-fame-could-be-acceptable-to-all/" rel="bookmark" title="Letter: In time, ‘Fame’ could be acceptable to all">Letter: In time, ‘Fame’ could be acceptable to all</a></h3>										

						</div><!-- END STORY -->
												<div class="more_stories">
							<h4><a href="/category/opinion/">More Opinion</a></h4>
						</div>
					</div>
				</div>
			</li>
		</ul>
		<!-- OPINION DROP END -->
	</li>
	<li class="obituaries"><a href="http://www.legacy.com/obituaries/salisburypost/">Obits</a></li>
	<li class="classifieds"><a href="http://marketplace.salisburypost.com/adhunter/SalisburyPost/">Classifieds</a>
		<!-- CLASSIFIEDS DROP -->
		<ul class="sub-nav">
			<li>
				<div class="contents">
					<div class="col first">
            <ul class="left">
                <li><a href="https://marketplace.salisburypost.com/Salisbury/">Place an Ad</a></li>
                <li><a href="http://marketplace.salisburypost.com/AdHunter/SalisburyPost/Home/Search?majorClass=1000">Jobs</a></li>
            </ul>
            <ul class="right">
            </ul>

					</div>
					<div class="col">
					</div>
					<div class="col last">
					</div>
				</div>
			</li>
		</ul>
		<!-- NEWS DROP END -->
	</li>
	<li class="calendar"><a href="https://www.salisburypost.com/calendar/">Calendar</a></li>
		<li class="Photos"><a href="http://salisburypost.mycapture.com/mycapture/index.asp">Photos</a>
</li>


	<li>
								<div class="search">
									<form method="get" class="searchForm" action="https://www.salisburypost.com/site-search">
										<input type="submit" class="searchButton" value="Go" />
										<input type="text" name="q" class="searchQuery" value="Search Salisbury Post..." onfocus="if(this.value=='Search Salisbury Post...'){this.value='';}" onblur="if(this.value==''){this.value='Search Salisbury Post...';}" />
									</form>
								</div>
	</li>
</ul>
							</nav>
							<div class="clearfix"></div>
						</header>

						<div id="content" class="flownews">
							<div id="notifications">
																
																							</div>


<div class="one_by_one_group">
<!-- one_by_one_wall-->
<div id='div-gpt-ad-one_by_one_wall'>
<script type='text/javascript'>
jQuery(window).load(function() { // These functions get called when everything has loaded
	if (!loggedin) {
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-one_by_one_wall'); });
  }
});
</script>
</div></div>

<!-- Boone Newspaper DurationMedia -->
<script type='text/javascript' src='https://pr.realvu.net/flip/2/c=E3TI_f=site_si=1015'></script>



							<div class="main_column">
								<div class="story">
									
									
                    <div class="gallery_group">
      <div id="story_photo_group">
        
                                    

              </div>
    </div>

		
									<div id="leftRail" class="">
										<ul class="sidebar">
																								<li id="recent-posts-2" class="widget widget_recent_entries">		<h2 class="widgettitle">Recent Posts</h2>
		<ul>
											<li>
					<a href="https://www.salisburypost.com/2020/08/16/local-students-will-have-two-historic-first-days-of-school-next-week/">Local students will have two historic first days of school next week</a>
									</li>
											<li>
					<a href="https://www.salisburypost.com/2020/08/16/taken-too-soon-retired-soldier-remembered-as-good-teammate-in-life-battle/">Taken too soon: Retired soldier remembered as good teammate in life, battle</a>
									</li>
											<li>
					<a href="https://www.salisburypost.com/2020/08/16/interpretive-walk-construction-begins-for-dixonville-lincoln-memorial-project-set-to-be-completed-in-december/">Interpretive walk construction begins for Dixonville-Lincoln Memorial project; set to be completed in December</a>
									</li>
											<li>
					<a href="https://www.salisburypost.com/2020/08/16/robert-trump-the-presidents-younger-brother-dead-at-71/">Robert Trump, the president&#8217;s younger brother, dead at 71</a>
									</li>
											<li>
					<a href="https://www.salisburypost.com/2020/08/16/bottle-and-can-opening-new-location-in-concord/">Bottle and Can opening new location in Concord</a>
									</li>
					</ul>
		</li>
										</ul>

										<div class="ad">
												<!-- ROS_160x600_Sidebar -->
<div id='div-gpt-ad-skyscraper'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-skyscraper'); });
  </script>
</div>										</div>
									</div><!-- END LEFTRAIL -->

									<div id="article">

										<h2>Doug Creamer column: He needs us</h2>

										<div class="byline">
											
											<a href="https://www.salisburypost.com/author/post.lifestyles/" rel="bookmark">
                        <img width="67" height="120" src="https://www.salisburypost.com/wp-content/uploads/sites/9/2020/01/Clock-Tower-logo-copy.jpg?w=67" class="avatar avatar-120 photo" alt="" srcset="https://www.salisburypost.com/wp-content/uploads/sites/9/2020/01/Clock-Tower-logo-copy.jpg 200w, https://www.salisburypost.com/wp-content/uploads/sites/9/2020/01/Clock-Tower-logo-copy.jpg?resize=168,300 168w, https://www.salisburypost.com/wp-content/uploads/sites/9/2020/01/Clock-Tower-logo-copy.jpg?resize=196,350 196w" sizes="(max-width: 67px) 100vw, 67px" />											</a>

											<p class="author">
                        <strong>By <a href="https://www.salisburypost.com/author/post-lifestyles/" rel="bookmark">Post Lifestyles</a></strong>
																							</p>
											<p class="social">
												<a class="email" href="mailto:lifestyles@salisburypost.com">Email the author</a>
																								 | 
													<a href="https://twitter.com/postlifestyles" target="_blank">twitter</a>
																							</p>
											<p class="pubStamp">Published 12:00 am Sunday, August 16, 2020</p>
																						<div class="clearfix"></div>
										</div><!-- END BYLINE -->

                    
                    <div class="one_by_one_group">
											<!-- extra_one_by_one -->
<div id='div-gpt-ad-extra_one_by_one'>
<script type='text/javascript'>
jQuery(window).load(function() { // These functions get called when everything has loaded
	if (!loggedin) {
    //console.log('========== BNI v10b not logged in ==========');
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-extra_one_by_one'); });
  } else { 
    //console.log('========== BNI v10b logged in ==========');
  }
});
</script>
</div>											<!-- extra_one_by_one_two -->
<div id='div-gpt-ad-extra_one_by_one_two'>
<script type='text/javascript'>
jQuery(window).load(function() { // These functions get called when everything has loaded
	if (!loggedin) {
    //console.log('========== BNI v10b not logged in ==========');
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-extra_one_by_one_two'); });
  } else { 
    //console.log('========== BNI v10b logged in ==========');
  }
});
  </script>
</div>											<!-- extra_oop -->
<div id='div-gpt-ad-extra_oop'>
<script type='text/javascript'>
jQuery(window).load(function() { // These functions get called when everything has loaded
	if (!loggedin) {
    //console.log('========== BNI v10b not logged in ==========');
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-extra_oop'); });
  } else { 
    //console.log('========== BNI v10b logged in ==========');
  }
});
</script>
</div>                    </div>

										<div class="p402_premium">

										
										<div class="story_detail">
											
        <table id="trinity-audio-table" style="width:100%; display: table;">
            <tr>
                <td id="trinity-audio-tab" style="border: none;">
                    <div id="trinity-audio-player-label"></div>
                    <script>var TRINITY_TTS_WP_CONFIG = {"cleanText":"Doug Creamer column: He needs us. By Doug Creamer\r\n\r\nI was talking with a friend the other day and was reminded of the first couple of years of our married lives. When we got married, we moved to the quiet town of Kenansville, in rural Duplin County. We loved our first years in Kenansville. Being young, we often wondered why we weren\u2019t living in a bigger city.\r\n\r\nWe got involved at a local church and worked hard at our jobs. One day in Sunday school class, the teacher asked me if I knew why we were living in that small town. With a smile, she said that she prayed for a godly man to be a teacher in her daughter\u2019s school. The next school year, I taught her daughter.\r\n\r\nIt\u2019s great how God answers our prayers. In order to answer our prayers, God has to find someone who is willing to say \u201cyes\u201d to him. Our willingness to say \u201cyes\u201d allowed this woman to realize that God really hears and answers her prayers. God needs us to do our part so he can answer people\u2019s prayers.\r\n\r\nI imagine that every one of us is praying for friends, neighbors, and loved ones who are lost and don\u2019t have a personal relationship with God. I often find myself praying, \u201cGod, please find someone who will spend time with this lost soul and will help to bring them home and into a personal relationship with you.\u201d\r\n\r\nFor God to answer that prayer, someone is going to have to say, \u201cHere am I Lord, send me.\u201d It is amazing to me that God limits himself to getting someone to go for him. He knows who the best person is who can help lead the lost sheep back to God. The trouble is, sometimes that person is unwilling to go.\r\n\r\nGod made each one of us with unique talents, skills and abilities that allow us to reach people in places that other people just can\u2019t go. I have never been very athletic, so for me to reach athletes with the love of God is a bit farfetched. I am not saying God can\u2019t use me, but I am not the best candidate for the job. I have several friends who love Jesus and who coach sports. They use that open door to reach kids. I know that they are the answer to many parents\u2019 pleas with God for their children.\r\n\r\nThroughout my teaching career, there were many opportunities to talk with students about faith, hope and love. Sometimes the doors and hearts were open, and other times they were closed. Sometimes the opportunity developed because of a personal crisis a student was facing. Other times it was a major world event like 9\/11 or the tragic death of a student that opened the doors of opportunity to share my reason for having hope.\r\n\r\nFor most people who meet you and me, it isn\u2019t anything we might say or do that will influence and change their hearts. It is the way we live and lead our lives. People are watching us and looking to see if Jesus really makes a difference for us personally. We may never know if or when we will make a difference, but it depends on how we carry ourselves that gives us the ability to speak into situations and people\u2019s lives.\r\n\r\nGod wants to use you. You may not feel qualified or ready for service. He just needs you to be available. My pastor often says if we are willing, then let God take care of the rest. He doesn\u2019t need you to be perfect. He needs you to be genuine. You will have good days and bad days, but do you live humbly, full of grace and mercy, and make people feel like they can approach God, with whom you have a personal relationship?\u00a0\u00a0That\u2019s all it takes.\r\n\r\nGod needs you. You might be the very person who will share your life and faith with someone\u2019s son or daughter and be the answer to many prayers. Opportunities happen almost every day. There are brokenhearted people who need to know that a loving God really exists and cares about them.\r\n\r\nI want to encourage you to look at the people in your life differently. They need you to be a light in their darkness. God wants every person to be saved. He needs you to be real, your genuine self. Live, love, cry, laugh and just be available to the people around you. They\u2019ll see that beautiful, attractive light in you and if their heart is open you might get the highest privilege of all\u2026introducing them to your heavenly father.\r\n\r\nContact Doug\u00a0Creamer at P.O. Box 777, Faith, NC 28041 or doug@dougcreamer.com","pluginVersion":"2.4.0"};</script><script type="text/javascript" src="https://trinitymedia.ai/player/trinity.php?viewkey=677143c5c1f3a1a2fcc0862c5951f602&postHash=fe6a7a90f2f9b7c941e5881b05d2078e&language=en-US&voiceGender=m&poweredby=1"></script>
                </td>
            </tr>
        </table><script>console.debug('TRINITY_WP', 'trinity_content_filter');</script><p><strong>By Doug Creamer</strong></p>
<p>I was talking with a friend the other day and was reminded of the first couple of years of our married lives. When we got married, we moved to the quiet town of Kenansville, in rural Duplin County. We loved our first years in Kenansville. Being young, we often wondered why we weren’t living in a bigger city.</p>
<p>We got involved at a local church and worked hard at our jobs. One day in Sunday school class, the teacher asked me if I knew why we were living in that small town. With a smile, she said that she prayed for a godly man to be a teacher in her daughter’s school. The next school year, I taught her daughter.</p>
<div id='mydfpad' class='ad300x ad'><div id='div-gpt-ad-instory-top' style='width:300px; height:250px; clear:both;'>
										<script type='text/javascript'>
										googletag.cmd.push(function() { googletag.display('div-gpt-ad-instory-top'); });
										</script>
										</div>
										</div><p>It’s great how God answers our prayers. In order to answer our prayers, God has to find someone who is willing to say “yes” to him. Our willingness to say “yes” allowed this woman to realize that God really hears and answers her prayers. God needs us to do our part so he can answer people’s prayers.</p>
<p>I imagine that every one of us is praying for friends, neighbors, and loved ones who are lost and don’t have a personal relationship with God. I often find myself praying, “God, please find someone who will spend time with this lost soul and will help to bring them home and into a personal relationship with you.”</p>
<p>For God to answer that prayer, someone is going to have to say, “Here am I Lord, send me.” It is amazing to me that God limits himself to getting someone to go for him. He knows who the best person is who can help lead the lost sheep back to God. The trouble is, sometimes that person is unwilling to go.</p>
<div id='mydfpad3' class='ad300x ad'>
                    <div id='div-gpt-ad-instory-third'>
                    <script type='text/javascript'>
                    googletag.cmd.push(function() { googletag.display('div-gpt-ad-instory-third'); });
                    </script>
                    </div>
                    </div><p>God made each one of us with unique talents, skills and abilities that allow us to reach people in places that other people just can’t go. I have never been very athletic, so for me to reach athletes with the love of God is a bit farfetched. I am not saying God can’t use me, but I am not the best candidate for the job. I have several friends who love Jesus and who coach sports. They use that open door to reach kids. I know that they are the answer to many parents’ pleas with God for their children.</p>
<p>Throughout my teaching career, there were many opportunities to talk with students about faith, hope and love. Sometimes the doors and hearts were open, and other times they were closed. Sometimes the opportunity developed because of a personal crisis a student was facing. Other times it was a major world event like 9/11 or the tragic death of a student that opened the doors of opportunity to share my reason for having hope.</p>
<p>For most people who meet you and me, it isn’t anything we might say or do that will influence and change their hearts. It is the way we live and lead our lives. People are watching us and looking to see if Jesus really makes a difference for us personally. We may never know if or when we will make a difference, but it depends on how we carry ourselves that gives us the ability to speak into situations and people’s lives.</p>
<p>God wants to use you. You may not feel qualified or ready for service. He just needs you to be available. My pastor often says if we are willing, then let God take care of the rest. He doesn’t need you to be perfect. He needs you to be genuine. You will have good days and bad days, but do you live humbly, full of grace and mercy, and make people feel like they can approach God, with whom you have a personal relationship?  That’s all it takes.</p>
<div id='mydfpad2' class='ad300x ad'>
											<div id='div-gpt-ad-instory-bottom' style='width:300px; height:250px; clear:both;'>
											<script type='text/javascript'>
											googletag.cmd.push(function() { googletag.display('div-gpt-ad-instory-bottom'); });
											</script>
											</div>
											</div><p>God needs you. You might be the very person who will share your life and faith with someone’s son or daughter and be the answer to many prayers. Opportunities happen almost every day. There are brokenhearted people who need to know that a loving God really exists and cares about them.</p>
<p>I want to encourage you to look at the people in your life differently. They need you to be a light in their darkness. God wants every person to be saved. He needs you to be real, your genuine self. Live, love, cry, laugh and just be available to the people around you. They’ll see that beautiful, attractive light in you and if their heart is open you might get the highest privilege of all…introducing them to your heavenly father.</p>
<p><em>Contact Doug <span class="il">Creamer</span> at P.O. Box 777, Faith, NC 28041 or <a href="mailto:doug@dougcreamer.com" target="_blank" rel="nofollow noopener noreferrer">doug@dougcreamer.com</a></em></p>

                                                                        <div class="author_bio">
                              <h4>About Post Lifestyles</h4>
                              <div class="headshot"><img width="67" height="120" src="https://www.salisburypost.com/wp-content/uploads/sites/9/2020/01/Clock-Tower-logo-copy.jpg?w=67" class="avatar avatar-120 photo" alt="" srcset="https://www.salisburypost.com/wp-content/uploads/sites/9/2020/01/Clock-Tower-logo-copy.jpg 200w, https://www.salisburypost.com/wp-content/uploads/sites/9/2020/01/Clock-Tower-logo-copy.jpg?resize=168,300 168w, https://www.salisburypost.com/wp-content/uploads/sites/9/2020/01/Clock-Tower-logo-copy.jpg?resize=196,350 196w" sizes="(max-width: 67px) 100vw, 67px" /></div>
                              <p>Visit us on Facebook: https://www.facebook.com/SalPostLifestyle/ and Twitter @postlifestlyes for more content</p>
                              <a href="mailto:lifestyles@salisburypost.com" class="more_articles"><img src="https://www.salisburypost.com/wp-content/themes/2016-bni/media/img/mail-32.png" alt="email author" /></a> 
                              <a href="https://www.salisburypost.com/author/post-lifestyles/" class="more_articles">More by Post</a> 
                              <div class="clearfix"></div>
                            </div>
                          



										</div><!-- END STORY_DETAIL -->
										</div><!-- END p402_premium (GOOGLE SURVEY) -->
										<script type="text/javascript">
											 var load_402_show_function = function () { try { _402_Show(); } catch(e) { } }
										</script>

                      <div class="prev_next_article">
  <!-- v 1.8 -->

                              <div class="next_article">
        <div class="padding">
          <div class="label">You Might Like</div>
                    <div class="thumb">
            <a href="https://www.salisburypost.com/2020/08/09/historic-salisbury-foundations-2020-octobertour-to-give-participants-new-views-into-old-landmarks/">
              <img src="https://www.salisburypost.com/wp-content/uploads/sites/9/2020/08/0809-LIFE-HSF-tour1.jpg?w=90&h=90&crop=1" alt="" width="50" height="50">
            </a>
          </div>
                    <h4> <a href="https://www.salisburypost.com/2020/08/09/historic-salisbury-foundations-2020-octobertour-to-give-participants-new-views-into-old-landmarks/">Historic Salisbury Foundation&#8217;s 2020 OctoberTour to give participants new views into old landmarks</a></h4>
          <p>SALISBURY — With a virtual edition of its annual OctoberTour, the Historic Salisbury Foundation will provide a glimpse into buildings... <a href="https://www.salisburypost.com/2020/08/09/historic-salisbury-foundations-2020-octobertour-to-give-participants-new-views-into-old-landmarks/">read more</a></p>
        </div>
      </div>
        <div class="clearfix"></div>
  </div>


												
											<div class="print_this">
													<a href="#">Print Article</a>
											</div><!-- END print_this -->


											<div class="articleOptions">
												<div class="admin">
</div>
<div class="clearfix"></div>


											</div>


                      <div class="rev_ad">
  <div id="rc-widget-61eef3" data-rc-widget data-widget-host="habitat" data-endpoint="//trends.revcontent.com" data-widget-id="112875"></div>
  <script type="text/javascript" src="https://assets.revcontent.com/master/delivery.js" defer="defer"></script>
</div>
  

<div class="connatix_ad" style="clear:both;">
<script>
!function(n){if(!window.cnx){window.cnx={},window.cnx.cmd=[];var t=n.createElement('iframe');t.display='none',t.onload=function(){var n=t.contentWindow.document;c=n.createElement('script'),c.src='//cd.connatix.com/connatix.player.js',c.setAttribute('async','1'),c.setAttribute('type','text/javascript'),n.body.appendChild(c)},n.head.appendChild(t)}}(document);
</script>
<script id="97fcfae9af944377a587c6aecda28e00">
  cnx.cmd.push(function() {
    cnx({
      playerId: 'b8b3adb8-39e6-4bca-8e9b-b12295f1fd23'
    }).render('97fcfae9af944377a587c6aecda28e00');
  });
</script>
</div>



											<div id="disqus_thread"></div>
<h3>Comments</h3>

  <div class="fb-comments" data-href="https://www.salisburypost.com/2020/08/16/doug-creamer-column-he-needs-us/" data-width="100%" data-numposts="5" data-colorscheme="light"></div>
 


<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
	js.async = true;
  js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.12&appId=168913723140235&autoLogAppEvents=1';
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

									</div>
									<div class="clearfix"></div>

								</div>
							</div>
							<div class="col last">
								
<ul class="sidebar">

	<li>
		<div class="ad first">
			<div id='div-gpt-ad-bigblock-1'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-1'); });
  </script>
</div>		</div>
		<div class="ad ">
			<div id='div-gpt-ad-bigblock-18'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-18'); });
  </script>
</div>		</div>


	</li>
	<style>.rpwe-block ul{
list-style: none !important;
margin-left: 0 !important;
padding-left: 0 !important;
}

.rpwe-block li{
border-bottom: 1px solid #eee;
margin-bottom: 10px;
padding-bottom: 10px;
list-style-type: none;
}

.rpwe-block a{
display: inline !important;
text-decoration: none;
}

.rpwe-block h3{
background: none !important;
clear: none;
margin-bottom: 0 !important;
margin-top: 0 !important;
font-weight: 400;
font-size: 12px !important;
line-height: 1.5em;
}

.rpwe-thumb{
border: 1px solid #eee !important;
box-shadow: none !important;
margin: 2px 10px 2px 0;
padding: 3px !important;
}

.rpwe-summary{
font-size: 12px;
}

.rpwe-time{
color: #bbb;
font-size: 11px;
}

.rpwe-comment{
color: #bbb;
font-size: 11px;
padding-left: 5px;
}

.rpwe-alignleft{
display: inline;
float: left;
}

.rpwe-alignright{
display: inline;
float: right;
}

.rpwe-aligncenter{
display: block;
margin-left: auto;
margin-right: auto;
}

.rpwe-clearfix:before,
.rpwe-clearfix:after{
content: "";
display: table !important;
}

.rpwe-clearfix:after{
clear: both;
}

.rpwe-clearfix{
zoom: 1;
}
</style><li id="rpwe_widget-2" class="widget rpwe_widget recent-posts-extended"><h2 class="widgettitle">LATEST LOCAL NEWS</h2>
<div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.salisburypost.com/2020/08/16/local-students-will-have-two-historic-first-days-of-school-next-week/" title="Permalink to Local students will have two historic first days of school next week" rel="bookmark">Local students will have two historic first days of school next week</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.salisburypost.com/2020/08/16/taken-too-soon-retired-soldier-remembered-as-good-teammate-in-life-battle/" title="Permalink to Taken too soon: Retired soldier remembered as good teammate in life, battle" rel="bookmark">Taken too soon: Retired soldier remembered as good teammate in life, battle</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.salisburypost.com/2020/08/16/interpretive-walk-construction-begins-for-dixonville-lincoln-memorial-project-set-to-be-completed-in-december/" title="Permalink to Interpretive walk construction begins for Dixonville-Lincoln Memorial project; set to be completed in December" rel="bookmark">Interpretive walk construction begins for Dixonville-Lincoln Memorial project; set to be completed in December</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.salisburypost.com/2020/08/16/robert-trump-the-presidents-younger-brother-dead-at-71/" title="Permalink to Robert Trump, the president&#8217;s younger brother, dead at 71" rel="bookmark">Robert Trump, the president&#8217;s younger brother, dead at 71</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.salisburypost.com/2020/08/16/bottle-and-can-opening-new-location-in-concord/" title="Permalink to Bottle and Can opening new location in Concord" rel="bookmark">Bottle and Can opening new location in Concord</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li>
<li id="custom_html-3" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget">		 <div data-cswidget="8627" > </div>
    <script type="text/javascript" async defer src="//cdn.cityspark.com/wid/get.js" > </script>
<iframe src="https://salisburypost.friends2follow.com/f2f/widget/html/socialstack/101/0/12/140/1/1/1/9/9/0" width="300px" height="600px" frameborder="0" scrolling="no"></iframe>
		
<div id="ap_widget_container_ca890116f6b1d98085d4fd61ca134e18"></div>
<script src="https://digitalservices.ap.org/assets/js/resizer.client.min.js" type="text/javascript"></script><iframe id="iframe_13947f0def41fee1d836d75ce3839363" style="overflow: hidden; min-width: 100%; border: none;" src="https://pro32.ap.org/iframe/widgets/content/13947f0def41fee1d836d75ce3839363" width="100%" height="100%" frameborder="1" allowfullscreen="allowfullscreen" onload="iFrameResize({}, '#iframe_13947f0def41fee1d836d75ce3839363');"></iframe>
<br />
		<a href="http://salisburypost.nc.newsmemory.com/marketplace.php">
			<img src="//www.salisburypost.com/wp-content/uploads/2016/10/shopping-marketplace-bar-for-web300.jpg" alt="">
		</a>
		<br />
</div></li>
	<li id="polls-widget-2" class="widget widget_polls-widget"><h2 class="widgettitle">Polls</h2>
<div id="polls-80" class="wp-polls">
	<form id="polls_form_80" class="wp-polls-form" action="/index.php" method="post">
		<p style="display: none;"><input type="hidden" id="poll_80_nonce" name="wp-polls-nonce" value="d4fc6be98d" /></p>
		<p style="display: none;"><input type="hidden" name="poll_id" value="80" /></p>
		<p style="text-align: center;"><strong>How do you plan to vote in November's election?</strong></p><div id="polls-80-ans" class="wp-polls-ans"><ul class="wp-polls-ul">
		<li><input type="radio" id="poll-answer-358" name="poll_80" value="358" /> <label for="poll-answer-358">Absentee by mail</label></li>
		<li><input type="radio" id="poll-answer-359" name="poll_80" value="359" /> <label for="poll-answer-359">Before Election Day at an early voting site</label></li>
		<li><input type="radio" id="poll-answer-360" name="poll_80" value="360" /> <label for="poll-answer-360">On Election Day</label></li>
		<li><input type="radio" id="poll-answer-361" name="poll_80" value="361" /> <label for="poll-answer-361">I don't plan to vote / I'm not a voter</label></li>
		</ul><p style="text-align: center;"><input type="button" name="vote" value="   Vote   " class="Buttons" onclick="poll_vote(80);" /></p><p style="text-align: center;"><a href="#ViewPollResults" onclick="poll_result(80); return false;" title="View Results Of This Poll">View Results</a></p></div>
	</form>
</div>
<div id="polls-80-loading" class="wp-polls-loading"><img src="https://www.salisburypost.com/wp-content/plugins/wp-polls/images/loading.gif" width="16" height="16" alt="Loading ..." title="Loading ..." class="wp-polls-image" />&nbsp;Loading ...</div>
<ul><li><a href="">Polls Archive</a></li></ul></li>
	<li>

		<div class="ad">
			<div id='div-gpt-ad-bigblock-2'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-2'); });
  </script>
</div>		</div>
	</li>
	<li>
		<div class="story_list widget">
			<ul>
							</ul>
		</div>
	</li>
		<li>
		<div class="ad">
			<div id='div-gpt-ad-bigblock-3'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-3'); });
  </script>
</div>		</div>
	</li>

	<style>.rpwe-block ul{
list-style: none !important;
margin-left: 0 !important;
padding-left: 0 !important;
}

.rpwe-block li{
border-bottom: 1px solid #eee;
margin-bottom: 10px;
padding-bottom: 10px;
list-style-type: none;
}

.rpwe-block a{
display: inline !important;
text-decoration: none;
}

.rpwe-block h3{
background: none !important;
clear: none;
margin-bottom: 0 !important;
margin-top: 0 !important;
font-weight: 400;
font-size: 12px !important;
line-height: 1.5em;
}

.rpwe-thumb{
border: 1px solid #eee !important;
box-shadow: none !important;
margin: 2px 10px 2px 0;
padding: 3px !important;
}

.rpwe-summary{
font-size: 12px;
}

.rpwe-time{
color: #bbb;
font-size: 11px;
}

.rpwe-comment{
color: #bbb;
font-size: 11px;
padding-left: 5px;
}

.rpwe-alignleft{
display: inline;
float: left;
}

.rpwe-alignright{
display: inline;
float: right;
}

.rpwe-aligncenter{
display: block;
margin-left: auto;
margin-right: auto;
}

.rpwe-clearfix:before,
.rpwe-clearfix:after{
content: "";
display: table !important;
}

.rpwe-clearfix:after{
clear: both;
}

.rpwe-clearfix{
zoom: 1;
}
</style><li id="rpwe_widget-5" class="widget rpwe_widget recent-posts-extended"><h2 class="widgettitle">LATEST LIFESTYLE</h2>
<div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.salisburypost.com/2020/08/16/danelle-cutting-stunning-blooms-gorgeous-displays-at-hurley-park/" title="Permalink to Danelle Cutting: Stunning blooms, gorgeous displays at Hurley Park" rel="bookmark">Danelle Cutting: Stunning blooms, gorgeous displays at Hurley Park</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.salisburypost.com/2020/08/16/mack-williams-the-house-that-lost-its-heart-light/" title="Permalink to Mack Williams: The house that lost its heart-light" rel="bookmark">Mack Williams: The house that lost its heart-light</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.salisburypost.com/2020/08/16/mask-the-city-volunteers-helping-with-effort-to-keep-everyone-safe-with-face-coverings/" title="Permalink to Mask the city: Volunteers helping with effort to keep everyone safe with face coverings" rel="bookmark">Mask the city: Volunteers helping with effort to keep everyone safe with face coverings</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.salisburypost.com/2020/08/16/dr-chris-magryta-column-if-they-must-go-online/" title="Permalink to Dr. Chris Magryta column: If they must go online" rel="bookmark">Dr. Chris Magryta column: If they must go online</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.salisburypost.com/2020/08/16/gotta-run-edie-brantley-smith-finds-her-home/" title="Permalink to Gotta run: Edie Brantley Smith finds her home" rel="bookmark">Gotta run: Edie Brantley Smith finds her home</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li>
<li id="custom_html-4" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget">		<a href="http://salisburypost.nc.newsmemory.com/ssindex.php">
			<img src="//www.salisburypost.com/wp-content/uploads/2016/10/special-section-bar-for-web300.jpg" alt="">
		</a>

		<br />
		<br />

		<script language="JavaScript" src="https://salisburypost.mycapture.com/datafeeds/28095.js"></script></div></li>
<li id="custom_html-7" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script src="https://digitalservices.ap.org/assets/js/resizer.client.min.js" type="text/javascript"></script><iframe id="iframe_bde00e4c8bdeeb4f1e1ee7efbf372056" style="overflow: hidden; min-width: 100%; border: none;" src="https://racing.ap.org/iframe/widgets/content/bde00e4c8bdeeb4f1e1ee7efbf372056" width="100%" height="100%" frameborder="1" allowfullscreen="allowfullscreen" onload="iFrameResize({}, '#iframe_bde00e4c8bdeeb4f1e1ee7efbf372056');"></iframe></div></li>

	<li>
		<div class="ad">
			<div id='div-gpt-ad-halfpage-1'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-halfpage-1'); });
  </script>
</div>		</div>
	</li>
  
</ul>							</div>

              							<div id="flow_news">
								<div id="flow_news_slider">
									<div class="wrap ca-wrapper">
																				<div class="story ca-item">
											<h4 class="category">Education</h4>
											<h3><a href="https://www.salisburypost.com/2020/08/16/local-students-will-have-two-historic-first-days-of-school-next-week/" rel="bookmark" title="Local students will have two historic first days of school next week">Local students will have two historic first days of school next week</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Local</h4>
											<h3><a href="https://www.salisburypost.com/2020/08/16/taken-too-soon-retired-soldier-remembered-as-good-teammate-in-life-battle/" rel="bookmark" title="Taken too soon: Retired soldier remembered as good teammate in life, battle">Taken too soon: Retired soldier remembered as good teammate in life, battle</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Local</h4>
											<h3><a href="https://www.salisburypost.com/2020/08/16/interpretive-walk-construction-begins-for-dixonville-lincoln-memorial-project-set-to-be-completed-in-december/" rel="bookmark" title="Interpretive walk construction begins for Dixonville-Lincoln Memorial project; set to be completed in December">Interpretive walk construction begins for Dixonville-Lincoln Memorial project; set to be completed in December</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Nation/World</h4>
											<h3><a href="https://www.salisburypost.com/2020/08/16/robert-trump-the-presidents-younger-brother-dead-at-71/" rel="bookmark" title="Robert Trump, the president&#8217;s younger brother, dead at 71">Robert Trump, the president&#8217;s younger brother, dead at 71</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Business</h4>
											<h3><a href="https://www.salisburypost.com/2020/08/16/bottle-and-can-opening-new-location-in-concord/" rel="bookmark" title="Bottle and Can opening new location in Concord">Bottle and Can opening new location in Concord</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Local</h4>
											<h3><a href="https://www.salisburypost.com/2020/08/16/marriages-for-july-2020/" rel="bookmark" title="Marriages for July 2020">Marriages for July 2020</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Local</h4>
											<h3><a href="https://www.salisburypost.com/2020/08/16/june-2020-corporations/" rel="bookmark" title="June 2020 corporations">June 2020 corporations</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Education</h4>
											<h3><a href="https://www.salisburypost.com/2020/08/16/more-than-500-bags-of-school-supplies-given-away-at-drive-thru-community-resource-fair/" rel="bookmark" title="More than 500 bags of school supplies given away at drive-thru Community Resource Fair">More than 500 bags of school supplies given away at drive-thru Community Resource Fair</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Lifestyle</h4>
											<h3><a href="https://www.salisburypost.com/2020/08/16/mask-the-city-volunteers-helping-with-effort-to-keep-everyone-safe-with-face-coverings/" rel="bookmark" title="Mask the city: Volunteers helping with effort to keep everyone safe with face coverings">Mask the city: Volunteers helping with effort to keep everyone safe with face coverings</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Local</h4>
											<h3><a href="https://www.salisburypost.com/2020/08/16/board-of-commissioners-to-consider-rental-of-west-end-plaza-for-gun-and-knife-show/" rel="bookmark" title="Board of Commissioners to consider rental of West End Plaza for gun and knife show">Board of Commissioners to consider rental of West End Plaza for gun and knife show</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Local</h4>
											<h3><a href="https://www.salisburypost.com/2020/08/16/story-behind-highway-patrol-handgun-started-with-someone-mowing-grass/" rel="bookmark" title="Story behind Highway Patrol handgun started with someone mowing grass">Story behind Highway Patrol handgun started with someone mowing grass</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Business</h4>
											<h3><a href="https://www.salisburypost.com/2020/08/16/biz-roundup-rowan-county-edc-to-host-information-webinar-on-job-retention-grant/" rel="bookmark" title="Biz Roundup: Rowan County EDC to host information webinar on job retention grant">Biz Roundup: Rowan County EDC to host information webinar on job retention grant</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Local</h4>
											<h3><a href="https://www.salisburypost.com/2020/08/16/march-2020-corporations/" rel="bookmark" title="March 2020 corporations">March 2020 corporations</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Business</h4>
											<h3><a href="https://www.salisburypost.com/2020/08/16/cannon-ballers-find-inventive-ways-to-use-vacant-spaces-in-ballpark/" rel="bookmark" title="Cannon Ballers find inventive ways to use vacant spaces in ballpark">Cannon Ballers find inventive ways to use vacant spaces in ballpark</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Coronavirus</h4>
											<h3><a href="https://www.salisburypost.com/2020/08/15/new-death-reported-at-autumn-care-as-outbreak-there-continues-to-grow/" rel="bookmark" title="New death reported at Autumn Care as outbreak there continues to grow">New death reported at Autumn Care as outbreak there continues to grow</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Nation/World</h4>
											<h3><a href="https://www.salisburypost.com/2020/08/15/ex-fbi-lawyer-to-plead-guilty-in-trump-russia-probe-review/" rel="bookmark" title="Ex-FBI lawyer to plead guilty in Trump-Russia probe review">Ex-FBI lawyer to plead guilty in Trump-Russia probe review</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Nation/World</h4>
											<h3><a href="https://www.salisburypost.com/2020/08/15/tropical-storm-josephine-closer-to-land-in-busy-atlantic-hurricane-season/" rel="bookmark" title="Tropical Storm Josephine closer to land in busy Atlantic hurricane season">Tropical Storm Josephine closer to land in busy Atlantic hurricane season</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Elections</h4>
											<h3><a href="https://www.salisburypost.com/2020/08/15/post-office-warns-states-about-mail-voting/" rel="bookmark" title="Post Office warns states about mail voting">Post Office warns states about mail voting</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Coronavirus</h4>
											<h3><a href="https://www.salisburypost.com/2020/08/15/unc-chapel-hill-sees-two-covid-outbreaks-in-reopened-dorms/" rel="bookmark" title="UNC-Chapel Hill sees two COVID outbreaks in reopened dorms">UNC-Chapel Hill sees two COVID outbreaks in reopened dorms</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Education</h4>
											<h3><a href="https://www.salisburypost.com/2020/08/14/all-three-school-board-seats-contested-as-filing-closes/" rel="bookmark" title="All three school board seats contested as filing closes">All three school board seats contested as filing closes</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Coronavirus</h4>
											<h3><a href="https://www.salisburypost.com/2020/08/14/spencer-nursing-home-has-covid-19-outbreak/" rel="bookmark" title="Spencer nursing home has COVID-19 outbreak">Spencer nursing home has COVID-19 outbreak</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Crime</h4>
											<h3><a href="https://www.salisburypost.com/2020/08/14/blotter-arrest-made-in-connection-with-kannapolis-shooting-incident/" rel="bookmark" title="Blotter: Arrest made in connection with Kannapolis shooting incident">Blotter: Arrest made in connection with Kannapolis shooting incident</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Crime</h4>
											<h3><a href="https://www.salisburypost.com/2020/08/14/sheriffs-office-man-faces-weapons-charge-after-fleeing-traffic-stop/" rel="bookmark" title="Sheriff&#8217;s office: Man faces weapons charge after fleeing traffic stop">Sheriff&#8217;s office: Man faces weapons charge after fleeing traffic stop</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News</h4>
											<h3><a href="https://www.salisburypost.com/2020/08/14/forest-abandons-lawsuit-challenging-cooper-executive-orders/" rel="bookmark" title="Forest abandons lawsuit challenging Cooper executive orders">Forest abandons lawsuit challenging Cooper executive orders</a></h3>
										</div><!-- END STORY -->
																			</div>
								</div>
							</div>

	<!-- SCREENSHIFT -->
<div id='div-gpt-ad-screenshift'>
<script type='text/javascript'>
jQuery(window).load(function() { // These functions get called when everything has loaded
	if (!loggedin) {
    //console.log('========== BNI v10b not logged in ==========');
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-screenshift'); });
  } else { 
    console.log('========== BNI v10b logged in ==========');
  }
});
</script>
</div>
 <div class="clearfix"></div>
<div class="ad">
</div>
		<div class="ad">
			<!-- ROS_728x90_Bottom -->		</div>
					</div>
					<div id="footer" class="clearfix">
						<div id="footSections" class="col">
							
							<h4>Sections</h4>
							<ol class="siteMap">
								<li><a href="https://www.salisburypost.com" rel="bookmark"><span>Home</span></a></li>
								<li><a href="https://www.salisburypost.com/category/news/"  title="" rel="bookmark"><span>News</span></a></li>
								<li><a href="https://www.salisburypost.com/category/sports/" title="" rel="bookmark"><span>Sports</span></a></li>
								<li><a href="https://www.salisburypost.com/category/opinion/" title="" rel="bookmark"><span>Opinion</span></a></li>
								<li><a href="https://www.salisburypost.com/category/lifestyle/" title="" rel="bookmark"><span>Lifestyle</span></a></li>
								<li><a href="https://www.salisburypost.com/category/health/" title="" rel="bookmark"><span>Health</span></a></li>
								<li><a href="https://www.salisburypost.com/category/faith/" title="" rel="bookmark"><span>Faith</span></a></li>
								<li><a href="http://www.legacy.com/obituaries/salisburypost/" title="" rel="bookmark"><span>Obituaries</span></a></li>
								<li><a href="http://marketplace.salisburypost.com/adhunter/SalisburyPost/" title="" rel="bookmark"><span>Classifieds</span></a></li>
								<li><a href="http://video.salisburypost.com/" title="" rel="bookmark"><span>Video</span></a></li>
							</ol>
						</div>


						<div id="footServices" class="col">
							
							<h4>Services</h4>
							<ol class="siteMap">
								<li><a href="https://www.salisburypost.com/services/about-us/" title="" rel="bookmark">About Us</a></li>
								<li><a href="https://www.salisburypost.com/customer-service/" title="" rel="bookmark">Contact Us</a></li>
								<li><a href="http://www.salisburypost.com/subscriptions/" title="" rel="nofollow">Subscribe</a></li>
								<li><a href="https://www.salisburypost.com/services/policies/" title="" rel="bookmark">Policies</a></li>
								<li><a href="https://www.salisburypost.com/services/policies/" title="" rel="nofollow">Terms of use</a></li>
								<li><a href="https://www.salisburypost.com/services/submit-a-news-tip/" title="" rel="nofollow">Submit a news tip</a></li>
								<li><a href="https://www.salisburypost.com/customer-service/" title="" rel="nofollow">Online Forms</a></li>
								<li><a href="https://www.salisburypost.com/editorial-social/" title="" rel="nofollow">Social Media</a></li>
								<li><a href="http://salisburypostnie.com/" title="" rel="nofollow">NIE - Newspapers In Education</a></li>
								<li><a href="http://salisburypost.mycapture.com/mycapture/index.asp" title="" rel="bookmark"><span>Purchase Photos</span></a></li>
				
								
															</ol>
						</div>


						<div id="footCopyright" class="col">
														<h4>Copyright</h4>
							<ol>
								<li>&copy; 2020, Salisbury Post</li>
							</ol>
						</div>

					</div>
				</div>


				        <script src="https://www.salisburypost.com/wp-content/themes/2016-bni/media/js/vendor/jquery.bxslider/jquery.bxslider.min.js"></script>
        <script src="https://www.salisburypost.com/wp-content/themes/2016-bni/media/js/vendor/jquery.contentcarousel.js"></script>
        <script src="https://www.salisburypost.com/wp-content/themes/2016-bni/media/js/vendor/jquery.easing.1.3.js"></script>
				<script src="https://www.salisburypost.com/wp-content/themes/2016-bni/media/js/vendor/jquery.timeago.js"></script>
        <script src="https://www.salisburypost.com/wp-content/themes/2016-bni/media/js/plugins.js?1592033368"></script>
        <script src="https://www.salisburypost.com/wp-content/themes/2016-bni/media/js/main.js?1592033368"></script>

        
				
<script type="text/javascript">tb_pathToImage = "https://www.salisburypost.com/wp-includes/js/thickbox/loadingAnimation.gif";tb_closeImage = "https://www.salisburypost.com/wp-includes/js/thickbox/tb-close.png";</script>
<script>
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/www.salisburypost.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
</script>
<script>
var pollsL10n = {"ajax_url":"https:\/\/www.salisburypost.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
</script>
<script type='text/javascript' src='https://www.salisburypost.com/_static/??-eJx1jsEOAjEIRH/ILupGowfjv2zLKrWlpNCsn2/dROPFC2GGeRNgEUfsUwuoEBXsTv4xled3GaJuoId8YUM2kNRuxAoZrRZGc1LLTAmdkLdW8V2SRdxcVyD847slJSWFdbqon+DvN11injAMmbjfr/myO5z323Ecj6f4AhHVRMc='></script>
<script type='text/javascript' src='https://stats.wp.com/e-202033.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.8.2',blog:'170543381',post:'472330',tz:'-4',srv:'www.salisburypost.com'} ]);
	_stq.push([ 'clickTrackerInit', '170543381', '472330' ]);
</script>
				</div><!-- END undertone -->
            </body>
</html>